Category: Appliances


I recently got ahold of one of these NEJE DK-8-KZ 1000mW Laser engravers and have been spending the weekend playing with it.

I haven’t got it to cut paper yet (haven’t got any spare paper) but have been engraving thin plywood.

While the working area is 36x36mm a resolution of 512x512mm it is still a lot of space to work on.

Being that it also runs on 5v means that once an image is uploaded to it, the laptop can be unplugged and the engraver run from a duel output phone charger (I have it running on an Anker)

the only slight issue a lot of people are getting is that it requires an un-signed driver and both Windows and OSX have trouble with it. This is down to the fact that it uses a CH340 USB to serial interface, which are becoming more common with Chinese “Knock-off” electronics.

Signed drivers do exist and a search of the internet will show them and they work well on OSX 10.11.06 (El Capitain). I haven’t upgraded to sierra yet even though it’s been out for ages so can’t say if it works on that.

While the software is a little simple, it means that a child of 12 years old can understand it. (yes I have tested a 12-year-old child with it!)

I have tested it with text and have been able to produce clear text readable at 2-3mm high.

This isn’t a full review and it needs a few mods to make it safe (the included glasses work but are rubbish) to make it safer for people who would like to watch it.

Well that is all I have for now as I have a few items to review and a few recycled tools to design for others to try and build.

So long for now.

 

So after nearly a year of not being used due to magic smoke and melted parts, my Ooznest Prusa I3 is alive again and reproducing.

After a problem with a tensioner braking and a real of ABS refusing to stick, I have now started printing new part for both the printer and my own custom Pi3 printer.

I have a list of parts I need to print for the printer and there is something else I should be printing to repair something in the house but I can’t remember what.

I’m sure it will come to me at some point.

After all the hassle and grief the printer is now back up and running with the new hot end and 0.3mm nozzle.

Still a lot to learn concerning the way the setting work but at least I can print again.

Well after a week where I nearly smashed it, the printer is up and running in a fashion. I haven’t calibrated the extruder steps as I’m having issue with the Bulldog lite Clicking when pushing filament through.

Thank you to the community to have given there help and support and to Ryan @ Ooznest for giving technical support and preventing me from braking it.

I may give up on converting this to duel and may use the parts instead to build a second.

Anyone know if I will have issues using the Arduino Mega 2560 adk instead of the mega 2560 as the heart of the new printer?

Someone took notice of my explorations and moved on to explore other sources for the cells.

Warning: I have been busy and haven’t been able to verify that this works!

Reader CMCristy started with what I wrote and when on to experiment, and wrote up his finding here.
PSP_Li_Ion_cell
I hope this is of help to fellow PSP owners.

Media Streaming Part 1

With Modern technology it seams wrong not to setup media streaming in your house.
The following is what I have learnt fighting with my setup. Currently my setup consist of
Server = Windows 7 laptop
iPad2,
Sony Erricson SK17i.

Software
iTunes
WMP
Cyberlink Powerdvd 11
Skifta
Cyberlink power dvd remote.

The Phone is advertised as DLNA which is supposed to be even easer then UPnP and its taken me all this time to get this working.
What was the culprit I hear you ask?
The Firewall!
I’m currently running ESET 5 and I had to disable Windows Firewall (a must if you install another proper firewall) then I had to reset Esets rules then rebuild them in interactive mode! but that still didn’t work (loosing hope at this time).
1st up go into Windows and set iTunes to share on a network, go into Cyberlink and set what you would like to share,then go into windows explorer and set which folders you want to share (Plenty of guides on the interwebs for that)
After a visit to google and youtube I found out first I have to connect the phone to the house’s wifi (Well duh I hear you say) but there is another step, Hidden in the setting is the media server!
If your on the same phone as me then you need to go to “connected Devices”, select a name and connect to a server which should be you PC.
Mine wouldn’t work at first so I had to wait for 10 mins how ever while I still had the windows explorer opened I went to the network folder and opened that. This folder shows what it can see on a network and for a while my phone was not recognised, after 10 mins it appeared and flicking back to my phone it also showed my pc and connected to it!
Step 1 down!
At this point go back to the phones home screen and select the photo/video icon, find a video and hold your finger on the video’s icon untill a green tick appears.
Click on the setting button then click share, now find “Play on device” in the next screen click on a Player device in none appear start up windows media player
at it should appear on the phone with a play button under it.
Click “Play” and wait till it starts playing on the computer.
Good 1 Application down !
Next, time for Cyberlink!
Load up Cyberlink on the pc, click music then click DLNA and your phone should appear!
Now click on device and you shouldn’t see anything except requests from the firewall, Start the Cyberlink app on your phone and you need to accept all firewall requests from the Cyberlink application and the phones IP address (Obtainable from the network devices menu of windows explorer)
If all worked then again your server should appear on the phone click it and it will take you to the apps media menu which will allow you to chose which part of Powerdvd you want to control. If your still with me all the better.
Next to get media from the pc to the phone, if the above is all working this will be easy.
First download and install “Skifta” to your phone,
Click on the little arrow of step one to select a server,
Click on the little arrow of step two to select the media player of choice on your phone
Click on browse and play media
The select the media you want to watch/listen to on phone!.
Told you it was easy.

Now for iTunes and Airplay.
That’s it for now as I have to go and win an auction for an airport express!

Arduino Mega ADK and Sony Erricson Xperia Mini Pro X17i works (well sort off!)

Well After all the banging, thumping and moaning I have managed to get the Xperia Mini Pro X17i to communicate with the Arduino Mega ADK!

First was patching of the Arduino code aka firmware, that took a lot of work mostly due to running the 1.0.1 version of the Arduino  programming environment. After editing loads of it then replacing the Google ADK files with the ones from http://www.circuitsathome.com/category/mcu/arduino/usb-shield I got the code to compile and upload but still couldn’t get the Xperia Mini Pro X17i to recognize it (well the phone charged but that’s it) I hit on an idea of using the Xperia live dock!
Powering everything up (mega using separate adapter) I connected the phone to the dock and “Unsupported accessory” message popped up, Yes its at least reading it in the liveware manager app.  After looking back through the arduino code I found the answer in AndroidAccessory.cpp

The following lines

#define USB_ACCESSORY_VENDOR_ID         0x18D1
#define USB_ACCESSORY_PRODUCT_ID        0x2D00

Needed to be changed but to what I hear you ask? The VENDOR_ID and PRODUCT_ID are incorrect (this is stated but I just ignored it causing some of the grief) After a bit of google I worked out how to get my ID code in Windows 7.

Once I had my codes I changed the lines to this

#define USB_ACCESSORY_VENDOR_ID         0x0FCE
#define USB_ACCESSORY_PRODUCT_ID        0x0166

Recompiled and now it’s recognized as Supported Hardware! (This is just for the Sony Erricson Xperia Mini Pro X17i)

Now I need to learn how to modify the Android demo app to make it work!

Note to get the demokit app to work I had to edit the manifest file (see previous file) which solved the errors then I cheated and just suppressed/ignored the warnings and it compiled, unfortunately there a bug in it which is preventing the app from displaying properly or recognizing the board!

I hope this information will be helpfull to you out there also venturing into this field.

つづく

So I took the plunge and upgraded my Revision 2 Arduino UNO to a Revision 3 Arduino Mega ADK which links up with android phones!

Why all the bother ? Upgrading the house electrics to LED’s. Hopefully when finished all that will be visible is a charging station on the wall that will also be the lighting system interface connection.
Just one big issue slowing all this down ……… I don’t know how to progame! I have the development environment set up I just need to learn how to build Android apps.

If this interests you keep wathing and hopefully soon I will have made something!

Aka all my lights are flashing

I have had a Bosch Tassimo tea machine for a few years now but for the last year it’s not been used due to the flashing lights phenomenon.

Today I found out what the problem was (a task in it’s self!) Holding in the big button and powering on I noticed the heating light lit on its own briefly before all the others came on.
Pulling off the covers and poking a tourch inside it I noticed alot of air bubble in the pipes (not good for any kind of plumbling) I grabbed the cleaning disk and filled up the water tank.
Putting the disk in and closing the lid made no difference so I held down the big button, After 20 seconds the cleaning process started and water started pumping around thesystem (heater wasn’t making any noise) and I noticed the bubbles being pushed through the system.
After the 2nd cleaning cycle the air bubbles were nearly all gone and the heater started up, after another cleaning cycle all the lights (bar the “Heating”) went out and heating light came on.
I popped out the cleaning disk and refilled the the water tank and left it on for 10 mins and it starting brewing away!

So in the end my problem was airlock.

I’m posting this in the hope that it will help other’s, remember readers
Hold in the big button for a long time!
If this help please drop me a message.
Right I better pop out and put the rest of the screws back in.